
MATHCAD TUTORIAL 
The Fundamentals 

 
Notice 

 
This manuscript contains the tutorial on using Mathcad 2000 Professional version as taken from the software built-in 
tutorial. Originally this material was extracted from MathCad 7 Professional, however, it has been updated by adding 
information from Mathcad 2000 Professional version. As such, it is possible that some of the information that was 
relevant to MathCad 7 might be present in this manuscript while id does not hold for MathCad200 Professional. Very 
minor editorial work has been done to present the material in a instruction form to fit the needs of the course Dynamic 
System I taught by the Department of Mechanical Engineering at FAMU-FSU College of Engineering which uses 
MathCad very intensively. Production of this manuscript if sorely for internal purposes and should not be used in any 
other form without permission from the owners of the work , MathSoft Inc. 

  

Introduction: The Mathcad Advantage 
 

Mathcad is a unique, powerful way to work with equations, numbers, text, and graphs. Unlike any other math software, 
Mathcad does math the same way you do. That's because it looks and works like a scratchpad and pencil. Mathcad's 
on-screen interface is a blank worksheet on which you can enter equations, graph data or functions, and annotate with 
text -- anywhere on the page. And instead of forcing you to use a programming-like syntax, Mathcad lets you use the 
language of mathematics. 
 
In a programming language, for example, equations look like this: 
 

x=(-B+SQRT(B**2-4*A*C))/(2*A) 
 

In a spreadsheet, equations go into cells looking something like this: 
 

+(-B1+SQRT(B1*B1-4*A1*C1))/(2*A1) 
 

In Mathcad, the same equation looks the way you would see it in a text or a reference book: 

x b b 2 4 a. c.

2 a.
 

The only difference is that Mathcad's equations and graphs are live. Change any data, variable, or equation, and 
Mathcad recalculates the math and redraws the graphs -- instantly.  With Mathcad, you can solve a wide range of 
technical problems -- from the simple to the very complex -- numerically or symbolically. You can also visualize 
equations and data with 2D and 3D graphing.   With Mathcad Electronic Books you also get a wealth of mathematical 
knowledge and reference material -- all live and ready to be dragged and dropped into your worksheets. Most 
important, Mathcad gives you all the power you need to get the job done -- from start to finish. With Mathcad you can 
truly do it all -- explore problems, formulate ideas, analyze data, model and test scenarios, select the best solution . . . 
then document, present, and communicate the results. Using  Mathcad's connections to the Worldwide Web, you can 
also share your Mathcad worksheets with colleagues and other professionals. This means you can collaborate easily 
during any phase of a project -- and you can do it in the rich and powerful language of mathematics. 



A Quick Tour of Mathcad's Features 
 

In Mathcad, you can . . . 
 
1. Do arithmetic with Mathcad's built-in functions and math operators 
 
The operator palettes accessible from the palette strip at the top of the window give you access to Mathcad's 
mathematical operators. First click in your worksheet to place a red crosshair cursor, then click on a button in one of 
these palettes to insert a math operator into your worksheet. To see a scrolling list of Mathcad's built-in functions, go to 
the Insert menu and select Function, or click on the Insert Function button on the toolbar. 

 

 
The red crosshair 
 
  

Insert Function button 
 
Here are a few examples. These calculations are computed internally to 15 places, but you can show fewer places in the 
answer -- just click on an answer and choose Number from the Format menu, then change the number in the 
Displayed Precision field in the dialog box. 
 
Get the square root and the power from the Arithmetic Palette, and type = to see the answer. For the four basic 
operations, use +, -, *,  and /  right from the keyboard. 
 

   

1.837 10 3.

100 35
2.3142353232=  

 
The standard engineering and math functions are built in. 

log 1347.2( ) sin 3
5

π.. 2.976=  

 
 
Mathcad's functions and operators handle complex numbers . . .  
 

2.3 4.7i( ) 3 e 3 2i 148.613 47.498i=  
 
. . . and units. To see the built-in units, choose Unit from the Insert menu, or click on the appropriate toolbar button. 
  

2350 km.

1 hr. 652.78 m sec 1=
 

 
Insert Unit button 
 
2. Define your own variables and functions 
 
The definition symbol := is in the Arithmetic Palette; you can also enter it by typing a colon (:). 

 
a 4 
 

a a 6=  
 



When you change a definition, Mathcad immediately recalculates any new values that depend on it.  
 

f x( ) sin x( )
x
a  

 
f 10( ) 0.218=  
 

Try it! Click just to the right of the 4 in the definition of a above so you see the blue editing lines: 
  

Then type [Backspace] once to get a placeholder: 
  

Now type 3. Click the mouse anywhere else on the screen and you'll  
see the answers change. 
 
3.  Evaluate functions and expressions over ranges 
 
The .. range operator is in the Arithmetic Palette and can also be entered by typing a semicolon [;] at the keyboard. 
Change the 2 in the definition of z to a 4 to see bigger tables. To create these tables, just type z=, f(z)= and so on. 

 
z 0 .5, 2..  

z
0

0.5
1

1.5
2

 
 

f z( )
0

3.835
3.366
2.66

1.819
 

exp f z( )( ) z.

0
23.156
28.959
21.444
12.326  

 
4. Plot functions quickly 
 



Use the X-Y Plot button in the Graph Palette, or type [Ctrl]2 to get a plot operator; then type expressions you want to 
plot in the middle placeholders on the x and y axes. You can type expressions on the y axis only, and Mathcad will 
choose a default range for you automatically on the x axis! You can enter several expressions separated by a comma (,) 
in these axes placeholders to see multiple traces.  

f x( )

sin x( )

x x,
10 0 10

2

0

2

4

 
 
 
5  Visualize data in two and three dimensions 
 
The following plots show how Mathcad can automatically interpolate a 3D scatter plot to create a surface plot. The 
same array of points is displayed in both plots. The first plot was created using Graph/3D Scatter Plot from the Insert 
menu, and the second plot was created using Graph/Surface Plot from the Insert menu. You can also use the 
corresponding buttons from the Graph Palette. 

X Y, Z,  



X Y, Z,

 

 
6. Compute sums and integrals 
 
The sum and integral operators are in the Calculus Palette. To build one of these expressions, click in your worksheet 
to position the red crosshair, click on the appropriate button in the palette, then fill in each placeholder.  
 

0

10

n

1
n!

=

2.7182818=

 
 

0

1
x1

1 x2
d 0.785=

 

 
7. Do matrix computations 
 
To enter a matrix, click on the 3 by 3 matrix icon in the Vector and Matrix Palette (or choose Matrix from the Insert 
menu), choose the number of rows and columns, then fill in the placeholders. 
 

A

4

5

7

5

0

2

1

12

8

 

To compute the inverse, just type A^-1=. 
 

A 1
0.074

0.135

0.031

0.117

0.12

0.132

0.184

0.163

0.077
=  

To find the determinant, type a vertical bar, |, or use the button on the Vector and Matrix Palette.  
 

A 326=  



 
8. Solve equations numerically 
 
Start Mathcad's root finder off with a guess . . . 

t 1 
. . . and Mathcad finds the closest root. 

root t2 cosh t( ) t, 1.621=  
 
9. Carry out symbolic operations 
By factoring , x

7 1  yields x 1( ) x6 x5 x4 x3 x2 x 1.  

and   
0

∞

xe x2
d     yields    1

2
π.

 

The quadratic expression 

x 1 1
x

 

has solution(s) 
1

2
1
2

5.

1
2

1
2

5.
 

 
You perform these symbolic operations by clicking on an expression and choosing commands from the Symbolics 
menu. You'll find commands for simplifying, expanding, factoring, differentiating, integrating, solving an equation, 
generating series expansions, carrying out symbolic matrix operations, and more. Copy the expression below to your 
main worksheet window, then click on it so you see it surrounded by blue editing lines (if necessary press the spacebar 
to select more of the expression); then choose Simplify from the Symbolics menu:

  
 
10. Create multiline procedures using new programming operators 
 
Use the operators on the Programming Palette in Mathcad Professional to build multiline Mathcad procedures with 
standard control structures: for and while loops, branching, recursion, and more. Programs are seamlessly integrated 
with Mathcad's live worksheets and math notation and can operate on scalars, vectors, arrays, and even arrays of arrays. 
Look at the following programming example. 

 

f x( ) J1 x( ) cos FRAME
20

2. π..  

a 0  
b 3.833  
xn 17  
rn 25  
i 0 xn..  
j 0 rn..  

NthRoot a n, ε,( ) estrt
a

n 2

estrt 1
1
n

estrt. a

n estrt n 1.

estrt n a εwhile

estrt

 



 
The above program implements Newton's method for finding nth roots of numbers within a tolerance e which is then 
used in the following example. 

rr i a b a
xn

i.  

ss j π 2 π. j.

rn  
 
Xc i j, rr i sin ss j

.
 

 
Yc i j, rr i cos ss j

.
 

 
Zc i j, f rr i sin ss j

.
 

 
NthRoot 7 5, 10 6, 1.476=  

 
11. Create animations to visualize results over time 
 
Any part of a Mathcad worksheet can be animated. Try animating the graph below by choosing Animate from the 
View menu, then entering values of FRAME from 0 to 20 in the dialog. Next drag-select the  regions below including 
the graph and equations to the right, and finally press Animate. You will see the animation pre-process. Then you can  
Mathcad lets you play back and save the animation as a standard video file or embed it in your worksheet.  

Xc Yc, Zc,

 

 
This only scratches the surface of Mathcad's mathematical features, but we hope it whets your appetite to explore the 
product further! In the next sections you'll learn how to create the basic elements of Mathcad worksheets: equations, 
text, and graphics. 
 



  

  
Lesson 1. Mathcad Tool Bars and Palettes 

 

Features of the Mathcad Window 
Before you move on to learning more about Mathcad's features and especially about building math and text in your 
own Mathcad worksheets, take a moment to look at the Mathcad application window in front of you.   

The Main Menu 
 
Here is your gateway to math, graphics, and symbolic functions and provides commands that handle the details of 
editing and managing your worksheets. Click on the Math and the Symbolics menus to see the array of computational 
functionality available to you in this product.  
 
Access to any Mathcad Electronic Books you may have installed is now available through the Help menu.   

The Math Palette  
 
Below the main menu is a tear-away bar whose buttons bring up palettes of math operators. If you let your mouse hover 
over each of the buttons on the bar in turn, you'll see a tool tip telling you what palette each button brings up: 

 
Arithmetic Palette  

Graph Palette 

 
Vector and Matrix Palette 
Evaluation Pallete  

Calculus Palette 

 
Evaluation and Boolean Palette  

Programming Palette  

Greek Symbol Palette  

Symbolic Keyword Palette 
 
 
Click on one of these buttons in the bar to bring up the associated operator palette. You can then use the operator 
palettes to insert math symbols right into your Mathcad worksheet.  
• The Tool Bar 
 
is another tear-away button bar that provides shortcuts for many common tasks, from worksheet opening and file 
saving to spell checking to bringing up lists of built-in functions and units. Depending on what you're doing in your 
worksheet, one or more of these buttons may appear grayed out. Tool tips will remind you of the functions of each of 
the buttons. One useful button is: 

 

 

 

 



 

Launches the Resource Center, that contains QuickSheets, template Mathcad worksheets that solve many common 
math tasks, from graphing to data analysis as well as extensive  reference tables, and other useful information. 
• The Format Bar 
 
This is where you can format your text and math at the click of a button. If the Format Bar is not showing, select 
Format Bar from the View Menu. 
 
• The Resource Center Navigational Controls  

appear whenever you have a Mathcad Electronic Book open and give you ways to browse among the sections of the 
Book and find topics of interest. This Tutorial you are reading is in fact a Mathcad Electronic Book! Just let your 
mouse hover over each of the navigational buttons at the top of this window to see a tool tip explaining what each one 
does. 
 
• Finally, the message line  

at the bottom of the Mathcad window gives you status alerts, tips, keyboard shortcuts, and other helpful information. It 
also lists the calculation status of your worksheet -- "auto" here means that the worksheet is in automatic mode, which 
means Mathcad will automatically recalculate any math expressions if you make edits to your worksheet. You can tell 
when Mathcad is recalculating because "WAIT" appears on the message line and the cursor changes to a flashing 
lightbulb.  Other information that appears on the message line is whether you have the Caps Lock or Num Lock key 
depressed on your keyboard, as well as the page number of the current worksheet.    

 
 
Step-by-Step Editing Guide 

 
 
A mathematical expression in Mathcad is a remarkable object: It is both a picture on your screen (or on paper when 
you print out a worksheet) and a set of instructions for computing something. Mathcad's equation editor is thus a 
unique blend of word processor and code generator, an efficient way of building expressions that look right and 
calculate correctly. The next lessons focus on teaching you the basics of entering, building, and editing math 
expressions, with a few detours to talk about text and graphics in Mathcad worksheets. These are orgainsed as follows 
 

Working with Mathcad Regions 
Entering Math and Text 
Working with Mathcad Styles and Templates 
Defining Variables 
Defining Functions 
Building Mathematical Expressions 
Editing Expressions 
Defining Range Variables 
Defining Vectors and Matrices 
Creating Graphs 
Formatting Math and Text 
Formatting Results 
Using Units 
Creating Programs 
Solving Systems of Equations 
Curve Fitting and Approximation 
 
 
 

 



  

  
Lesson 2:Working with Mathcad Regions 

 

Every Mathcad equation, text paragraph, and plot in a worksheet is a separate object called a region.  You can select a 
single region by clicking in math or text in your worksheet. The region then shows up with a thin rectangle around it. If 
you move your cursor to one of the edges of the region, notice how your cursor changes to a small hand -- which lets 
you move the region. Try dragging the regions below to your worksheet window. Note that if you click in the math 
region, you will see blue selecting lines under the material currently selected. If you click in a text region, you will see 
black boxes at each corner and the middle of each line. These boxes allow you to resize text regions, which you can do 
in your worksheet window, but not in the Resource Center. 
 
A math region   x 100  A text region  The assignment above was created by typing x:100 
 
Moving Regions 
You can also drag-select multiple regions at one time to move them around on the screen to your liking. To move 
regions in your worksheet: 
• Click in an empty area to position the red crosshair cursor in your worksheet and then drag-select regions so they 

appear in dashed selection boxes. 
• Move your cursor inside one of the boxes. Notice that it becomes a small black hand. 
• Hold down your mouse button and drag your mouse. All of the selected regions will move with it. 
 
Once you have the regions positioned the way you want them, release the mouse button and click on an empty part of 
the screen to deselect the regions. 
 
Hint: If you want to grab a group of regions, but want to deselect one of them, use shift click on individual regions, to 
do so. 
 
Another way to see the regions in your worksheet is to choose Regions from the View menu. The region boundaries 
will be highlighted against a contrasting background.  An important property of Mathcad is that it reads your document 
from left to right and top to bottom, just as you read a book. For an example of what this means, select the y2 = 100 
below and drag it above the definition of y  (the definition of the variable is done in Mathcad with the colon-equals 
symbol; more on that later). You will see that Mathcad is no longer able to tell you what y 2  equals because it doesn't 
know what y equals yet. Notice that if you drag the region below the original assignment, it computes! 

y 10  

y2 100=  
You can also easily delete selected regions. Select the math regions above in dashed line boxes and choose Cut from 
the Edit menu.  (You may need to copy the regions to a worksheet of your own to try this out.) Now click in the empty 
space above and choose Paste from the Edit menu to reinstate the equations. You can see how this can be useful if you 
delete something by accident. Using this technique, you can select many regions at once and clear them away.  And, if 
you make a mistake, you can easily bring the regions back, provided you bring them back before you Cut something 
else. 

 



  

  
Lesson 3: Entering Math and Text 

 

Entering Math 
Click your mouse in the blank space below so you see a red crosshair cursor. Now type: 
    Type 1+  See on screen                    

After you type the + you see a little black box delimited by blue editing lines. In Mathcad this black box is called a 
placeholder. If you continue typing, whatever you type next will appear in the placeholder. For example, type 2 in the 
placeholder, then press the equals key (=) to see the result. 
 
If you click outside the region, or press [Enter], you should see:  

The basic operators are listed below, along with their keystrokes and Arithmetic Palette button equivalents. To see the 
Arithmetic Palette, click on the Math Palette button.    

Math Palette button 
 
Operation            Keystroke            Button                  Example                                                         

                 

 

Addition                      +                           

              

2 2 4=  

                                                        

 

Subtraction                -                    2 2 0=  

                                                       

 

Multiplication            *                    2 2. 4=  

                                                         

 

Division                   /                     2
2

1=  

                                                       

 

Powers                     ^                     2 2 4=  
 
Notice that math in a Mathcad worksheet appears in familiar math notation -- multiplication as a raised dot, division 
with a fraction bar, exponents in a raised position, and so on. 
 
Entering Text 
To create a text region, click in a blank area of the screen to position the red crosshair cursor and type a double-quote 
["]. You can also just start typing, and as soon as you type a space, Mathcad converts from a math region to a text 
region. Typing certain characters used in math will not automatically convert to a text region, so it is always safest to 
use the double-quotes.Now you can now type whatever you like, just as in a word processor. Notice that as the text 
region grows, a black box appears around it, and there are resizing "handles" on the right and bottom edges of the 
rectangle. Once you are done, click outside the text region to go back to inputting math. The black selection box 
disappears when you're no longer working in the text region.  

  



 

Lesson 4: Working with Mathcad Styles and Templates 
 

Introduction  
Two new features in Mathcad 7 are styles and templates, which work much like those in word processors. We have 
provided several templates for your use or revision, each containing a number of styles. You can also create your own 
styles and store them in a template so they are available for other documents. 
 
Using a Template 
To use a built-in template, choose File/New, then choose a template from the templates listed, or browse to your own 
template directory. Just substitute your own text or bitmaps in any of the placeholders, or use or revise the built-in 
styles. 
 
Using Styles 
The styles in each template are visible from the first pull- down menu in the Format Bar. If the Format Bar is not 
visible, choose View Format Bar. Styles save you work, because you can quickly apply a style such as Heading One 
to specific text regions, instead of having to redefine the font, size, and indents for each new heading. To create or 
modify a style, choose Format Style. To save your styles for use in new files, you must make a template file.  
 
Creating a Template 
Creating a new template or revising another template is very easy. You can 
• create text styles and number formats  
• set the fonts and sizes for constants and variables in math regions 
• add any bitmaps that you want on every page such as a line across the top or bottom of the file 
• put page numbers, filenames, and the current date in headers or footers 
• set  the formats for numbers 
Then Save As and choose under File of Type, Template. Make sure to have the file extension be .mct. Your settings, 
styles, and bitmaps will be available for the next file you create, saving you the time of redoing that work for each file. 
This will also help make your files more consistent. 

 
 
 
 
 
  

  
Lesson 5: Defining Variables 

 

Often you will want to define a number as a name you can use in subsequent calculations. For example, click to 
position the red crosshair in an empty space below and type: 
 
Type age:23 See on screen 

                          

 

 
Notice that when you type the colon [:] key or, press the assignment operator key   

on the Arithmetic Palette, Mathcad displays :=. The assignment operator ("colon equals") in Mathcad is used for 
definitions. To see what age equals, you just type the name followed by the equals sign: 
 
Type  age= 
 



If you wanted to assign a different value to age, just click to the right of the 23 on the right-hand side of the definition 
of  age above, backspace over it to delete it, and enter the new value. Notice that as soon as you press [Enter], age= 
changes as well.  Because of this ability to vary the value of a name, this type of definition is called a variable in 
Mathcad.  You can now use a Mathcad variable in an equation: 

age 23  
age 10. 230=  

Or, use the variable to define another variable: 
old age 10.  
old 230=  

Try defining some variables of your own (you can call your variables x or money_spent or any other names you 
can think of) and use them in equations in your main worksheet. Remember that you use the assignment operator [:] for 
definitions, and you type  [= ] to calculate an answer. 

 
 
 
  

  
Lesson 6: Defining Functions 

 

The syntax used for defining a function in Mathcad is the same as you see in textbooks. For example, position the red 
crosshair in a blank area and try typing: 
 
Type f(x):x^2  See on screen 

                         

 

 
Notice that you use the assignment operator to define functions, just as you use the assignment operator to define 
variables in Mathcad. Once you've defined a function like f x( ) , you can use it in a  number of ways: 

f x( ) x 2
 

 
. . . Plug in a numerical value as the argument of f x( ) . 

f 10( ) 100=  
 
. . . Define a variable and plug it in as the argument of f x( ) . 

x 3  
f x( ) 9=  

. . . Define a range variable (more on this later) and plug it in as the argument of f x( )  to see a table of values. 
a 0 3..  

f a( )
0
1
4
9

 

. . . Even define another function in terms of f x( ) . 
g y( ) f y( ) 6  
g x( ) 15=  

 
You can define a function using expressions you build up from the keyboard or from the palettes of math operators, as 
described above, and you can also include any of Mathcad's hundreds of built-in functions. To see a scrolling list of 



built-in functions along with brief descriptions, select Function from the Insert menu, or click on the   

button on the toolbar. The Insert Function dialog box, pictured below, lets you insert a function name directly into a 
math placeholder in your worksheet.  
 

 
You can also type the name of any built-in function directly from the keyboard. Here are just a few examples that use 
some of Mathcad's built-in functions. 
 
Trig and Logs 
 

ln 26( ) 3.258=  
 

csc 45 deg.( ) 1 2=  
 
Matrix Functions 
 

identity 3( )

1

0

0

0

1

0

0

0

1

=
 

 
cols identity 6( )( ) 6=  

 
 

 
 
 
 
 
 
 
 
 
 
 

 



 

  
Lesson 7: Building Mathematical Expressions 

 

Click to position the red crosshair in the empty space below and type the following. Pay particular attention to what 
happens when you press the spacebar: 
 
Type  f(x):x+6[Spacebar]*(x^3[Spacebar]-1)  See on screen  

The first time you pressed [Spacebar], you selected  

in blue editing lines. So, when you typed the multiplication sign, you were multiplying this entire expression by the 
expression that followed. If you hadn't pressed [Spacebar] the first time, you would have seen  

which is a completely different expression. When you pressed [Spacebar] the second time, x3 was selected in the blue 

editing lines. Therefore, when you typed -1, you were performing subtraction on the entire expression x3
. Compare 

what you typed above to what happens when you type f(x):x+6*(x^3-1) you probably get something that looks like  

The exponent operator is called a sticky operator because your keystrokes will "stick" to the exponent until you 
specifically ask to get out by pressing [Spacebar]. This stickiness applies to exponents, square roots, subscripts, and 
division. To create the expression type below: 
  

follow the following steps: 
 
Type  x^2[Spacebar] 

Now x2
 is selected in blue editing lines, then Type +3[Spacebar] so that the entire equation is in the editing lines, 

then Type /5[Enter] and done! 
 
If you try entering the expression again without pressing [Spacebar] after typing +3 you should get 

 
 
And if try typing x^1/t^2[Spacebar][Spacebar][Spacebar]/3 You should get 



 

You may need to create some of your own equations in your main worksheet window in order to get a better feel for 
sticky operators. 

 



  

  
Lesson 8: Editing Expressions 

 

Understanding the structure of expressions in Mathcad will help you edit them efficiently. Looking at the highlighted 
equation below, do the following with the mouse: 

 

                 

f x( ) x2 5
8

x3  

 
• Click on the square root symbol. Notice that the square root and everything under it is selected in blue editing 

lines. 
• Click immediately to the right of the 5 under the radical, then start pressing [Spacebar]. Notice how more and 

more of the expression is selected in blue editing lines. 

• Click immediately to the left of the 3 in the exponent of  x3 , then start pressing [Spacebar]. Notice how more and 
more of the expression is selected in blue editing lines. 

 
The blue editing lines define a subexpression that will be operated on by the next operator or expression you type. If 
your editing lines are positioned to the left of an expression, the next operator or expression you type will appear to the 
left of the vertical line; if your editing lines are to the right of an expression, the next thing you type will appear to the 
right of the vertical line.  
Now notice what happens when you use other mouse selection methods on parts of the highlighted equation below:  

              
f x( ) x2 5

8
x3  

• Double-click on the x  in the expression f x( ) . Notice that double-clicking selects the variable in reverse video.  

• Click to the left of the x2 under the radical, then start dragging your mouse to the right. Notice how more and 
more of the expression is selected in reverse video. 

 
When you select a part of a math expression in reverse video, the next operator or expression you type will replace the 
selected expression. This is probably how you're already used to editing text on the screen in most word processors. 
Try It Out! 

f x( )
x 2 5

8
x 3  

• If you want to replace the 5 with a 6 , double-click on the 5 so it appears in reverse video, then type 6.   
• If you want to replace the division with multiplication, click to the left of the 8 in the denominator, press the 

[Backspace] key, and type [*].   
• If you want to take the square root of the entire right side of the equation, click to the left of the radical and press 

[Spacebar] until the entire right-hand side is selected in blue editing lines. Then type a backslash [\]s. 
• If you want to subtract 1

2
x.  instead of x 3  on the right-hand side, drag-select the x 3  and then type 

1/2[Spacebar]*x.   
 
If you are editing an expression and make a mistake, just select Undo from the Edit menu to return to the original 
expression. Or, if you recently saved your worksheet, close it without saving changes and reopen it. 
 
 
Here is another example you can try to get the hang of editing math in Mathcad.  Enter the following lines in the 
MathCad editor 



 
x 1.5  
 

2 x 2. 3
2

x. 2 8.75=  

then edit the last expression so that it looks like 
 

2 x 5( ) 2. 5
2

x. 2 22.75=
 

The variable x has been defined at the beginning so you can see the effects of your edits. 
 
Here Are the Steps . . .  
• First, change the x 2  to x 5( ) 2 . Double-click on the first  x in the expression and then type x-5. 
• Now change the leading constant from 2 to -2. Click immediately to the left of the leading 2 so you see blue 

editing lines, and then type -. 

• Now edit the fraction 3
2

 . Double-click on the 3 in the fraction bar to select it and then type 5. 

• Finally, change the addition at the end to a subtraction. Click immediately to the left of the final equals sign in the 
expression so you see blue editing lines. Press [Backspace] to delete the plus sign. Now type [-].  

 
So, incorporating everything you've learned so far, try to reproduce  
the following equations yourself: 

score 3 
 

result
score 6 1

2

score 2 3  
 
result 0.583=  

 
You should have typed 
 

score:3[Enter] 
result:score+6[Spacebar]\+1/2[Spacebar] 
[Spacebar]/score^2[Spacebar]-3[Enter] 
result=[Enter] 

 
If you had trouble with this, try practicing with some more examples until you feel comfortable editing Mathcad 
expressions.   

 
 
 
 
 
 
 
 
 
 
 
 
  

  



Lesson 9: Defining Range Variables 
 

Assigning a range of values to a variable is straightforward in Mathcad. For example, to create a variable x that runs 
from 0 to 10, just click to position the red crosshair in some free space and type x:0;10 
After clicking away, you should see  

Notice that when you type the semicolon character [;], it displays on the screen as two dots (..) followed by a 
placeholder. This is Mathcad's range variable operator. Another way to put the range variable operator in your 
worksheet is with the Range Variable button   

on the Math Palette. 
You can now use a range variable as you would any other variable. Notice that Mathcad creates an output table -- a 
vertical series of boxes that contain numbers -- when you type [=] after an expression involving a range variable. 

x 0 5..  

f x( ) 2 x 5( ) 2. 5
2

x. 2  

 
Type x= See on screen 

x
0
1
2
3
4
5

 

 
Type f(x)= See on screen 

f x( )
52

31.5
15
2.5
6

10.5
 

 
If you want your range to be in increments other than 1 (the default), enter the next value in the range after the first 
one. For example, to create a range variable x that goes from 1 to 10 in increments of 0.1, type: 
 
Type x:1,1.1;10 See on screen 

 
 

Notice that you typed a comma before the second value in the range, and then you typed the semicolon [;] after the 
second value. Here are some other examples, along with the keystrokes used to create them: 
 
Type x:1,1.1;1.8 See on screen 



x 1 1.1, 1.8..  
 
Type data:-10,-8;0 See on screen 

data 10 8, 0..  
 
Type n:202,192;102 See on screen 

n 202 192, 102..  
 
Here the range goes down! 
 
 
Type x= See on screen 

x
1

1.1
1.2
1.3
1.4
1.5
1.6
1.7
1.8

 
 
Type data= See on screen 
 

data
10
8
6
4
2

0
 

 
 
Type n= See on screen 



n
202
192
182
172
162
152
142
132
122
112
102

  

 

Try defining your own range variable and using it in an expression below. 
 



  

  
Lesson 10: Defining Vectors and Matrices 

 

The examples you've seen so far have involved single numbers or scalars. Mathcad has many powerful features and 
functions, however, for dealing with arrays of numbers, such as vectors and matrices. Creating a vector or matrix in 
Mathcad involves just choosing the dimensions of the array and filling in the placeholders. For example, to create a 
vector v like the one shown below, click to position the red crosshair in some free space and 
• Type v: 
• Choose Matrix from the Insert menu (or click on the  matrix button inside the Vector and Matrix Palette)  

• Fill in the appropriate number of rows and columns. For example, the vector below has 3 rows and 1 column. 
• Click on Insert. 
• Fill in the placeholders with the appropriate values. Use [Tab] to move from placeholder to placeholder inside the 

vector, or click on the appropriate placeholder to select it. 

v
3.3

1.2

8

 

To access a particular element of a vector, you use the subscript operator, which you create by typing a left square 
bracket ( [ ), or by using the   
 
button in the Arithmetic Palette. By default the first element has the index 0: 
 
Type v[0= See on screen 
 

v0 3.3=  

The next element has the index 1: 
 
Type v[1= See on screen 

v1 1.2=  

The last element has the index 2, and so on: 
 
Type v[2= See on screen 

v 2 8=  
If  z is a matix, then the 3rd element in the first column can be accessed  by typing v[2,0 
 
For convenience, you can define the index as a range variable to access all of the elements at once: 
 
Type i:0;2  See on screen 

i 0 2..  
Then 
Type v[i= See on screen 
 

vi

3.3
1.2
8

 

For your exercise, try defining a vector and its index. It's important to understand that an index for a vector will always 
be a range of consecutive integers in Mathcad, starting from 0. Any values not specifically defined by you will be 

 



defined to equal 0 by Mathcad.  For example, consider the followings: 
 
Type i:2;5  See on screen 

i 2 5..  
Type wrong[i:1 See on screen 
 

wrong i 1 

Type wrong= See on screen 
 

wrong

0
0
1
1
1
1

=

 

You might expect the vector wrong  to have four elements (the 2nd, 3rd, 4th and 5th). However, as you can see, it has 
six. This is because internally, Mathcad still keeps track of the 0th and 1st elements. And because these were not 
specifically defined, Mathcad made them equal to 0. 
 
It is useful to use vector elements as arguments of functions.  For example, we'll use the constants and function defined 
below: 

b 9.7  
 
a 1.1 

f v( ) v 3

9 b 2.
v. a  

Now define a vector and use its elements as an argument of the function: 

v
3.3
1.2

8  
 
i 0 2..  
 

f vi

1.11
1.098
1.131

 
 

Try defining a vector and using its elements in a function. You can also use vectors as arguments of functions. For 
example: 
 
Type f(x):[Ctrl]4x See on screen 

f x( ) x  
Here we use the vector summation operator, which is also available via the  

button on the Vector and Matrix Palette. 

v

3.3

1.2

8
=

 
 



f v( ) 10.1=  
Most of the vector and matrix operators can be found in the Vector and Matrix Palette, but here is a listing of a few 
basics: 
 
Operation            Keystroke         Palette Button      Display 

                                                          

 

Dot product        [Shift]8                  v w.   (Displays like scalar multiplication). 
 

                                                          

 

Cross product       [Ctrl]8                   v w 
 

                                                         

 

Determinant                |                       M  
 

                                                        

 

Column             [Ctrl]6                    M 2< > (Returns the 3rd column of M. By default, the index for 
the first column is 0) 
 
Mathcad has a wide variety of built-in functions for manipulating vectors and matrices. Here is a small sampling, 
using the matrix M  defined below: 

M
7

6

5

9

8

7

1

2

3

 

Purpose                                        Example 
Number of columns                      cols M( ) 3=  
Number of rows                            rows M( ) 3=  
Largest value in matrix                 max M( ) 9=  

Eigenvalues of a matrix               
eigenvals M( )

11.526
11.463

1.938

=
 

 



  

  
Lesson 11: Creating Graphs 

 

Mathcad makes it easy for you to create an x-y plot. Just click in a new file, type an expression that depends on one 
variable, for example,  sin(x), and then click on the X-Y Plot button   

in the Graph Palette, or choose X-Y Plot from the Insert/Graph menu. Then press [Enter]. Voila, a plot! You should 
see a nicely formatted plot that looks like this:  

0.999982

0.999982

sin x( )

1010 x

10 5 0 5 10

1

0.5

0.5

1

 
Try It Out!  
The expression you plot doesn't even have to be a function of x. Try typing y^2[spacebar]-3*y, followed by the @ key 
(a shortcut for creating an x-y plot). Mathcad will plot over a reasonable default range for the dependent variable in 
your expression. Here are a couple of other expressions you can try plotting in this way: 
 

1. z cos z( ).  
 
2. 1

1 x2
 

 
Graphing a Function Using Range Variables 
When you graphed the above expressions, Mathcad was choosing a default range for the dependent variable. You can 
have control over the range of values that are plotted. To graph a simple function using a range variable, do the 
following: 
• Define a function of one variable that you wish to plot. For example, graph the following function: Type f(x):-

x^2[Spacebar]+8*x-27 See on screen 
f x( ) x2 8 x. 27  

• Define an independent variable for the horizontal axis. For example: Type x:0;10 See on screen 
x 0 10..  

• Create your plot by clicking in the worksheet window, then type @  to create the x-y plot and type x in the middle 
placeholder on the horizontal axis and type f(x) in the middle placeholder on the vertical axis. Then press [Enter]. 

 
Your plot should look like this: 



f x( )

x

0 5 10

50

40

30

20

10

 

Those of you familiar with the plot of f x( )  will notice that the trace looks a little rough. To smooth the trace out, try 
changing the definition of x highlighted above to x 0 0.1, 10.. . The smaller increment (or step) means more 
points calculated, which means more plotted, which makes the trace smoother because Mathcad is simply connecting 
the dots. 
 
To format an x-y plot, just double-click on it (or choose Graph from the Format menu) to bring up a formatting dialog 
box. The tabbed dialog box lets you change options for logarithmic axes, grid lines, legends, trace types, markers, 
colors, axis limits, and more. Experiment with the x-y plot below. Double-clicking on any Mathcad plot -- contour, 
surface, polar, vector, etc. -- brings up an appropriate formatting dialog box.  

x 0 0.1, 10..  

f x( )

x

0 5 10

50

40

30

20

10

 

 
Graphing Vector Elements 
Here is a vector of data points called money_spent. We created the vector using the Matrix command on the Insert 
menu; our vector below has 8 rows and 1 column. 



money_spent

2

3

6

8

11

12.5

14

17

 

To plot these data points, the horizontal axis must be either (a) an index variable into the variable money_spen or (b) 
another vector with the same number of elements.  For case (a), first define an index into the vector: 
 
Type i:0;7 See on screen 

i 0 7..  
Create your plot by typing [@] and typing 
 
Type money_spent[i See on screen 

money_spent i 
 
in the placeholder on the y axis, and i in the placeholder on the x axis. You should see a plot similar to this: 

 
Notice here that box symbols have been used on a dashed blue line. 
 
To demonstrate case (b), plotting two vectors of equal size against each other, we will define a second vector, called 
day: 

day

1
2

3
5
7

8
10
12  

 



money_spent

2

3

6

8

11

12.5

14

17

=

 

Now it's easy: Create the plot by typing @, as above, and type 
 
Type money_spent See on screen 

money_spent  
 
in the placeholder on the y axis, and  
 
Type day See on screen 

day  
 
in the placeholder on the x axis.  
 
The resulting plot should look similar to this:   

0 5 10 15

5

10

15

20
 

Here the "points" trace type has been used with magenta O's. Notice that grid lines have been turned off on both axes. 
 
Graphing a Function of Vector Elements 
You can plot a function over a domain that doesn't contain evenly spaced points. For example, your domain could 
consist of a vector of values. Plotting a function of vector elements entails defining a function, defining a vector which 
will be the domain for the function, and plotting. An example of this is: 
Define a function of one variable. 
 
Type f(x):x^2 See on screen 

f x( ) x 2  
Define a vector of numbers to be the domain for the function. Type x: followed by [Ctrl]M , and fill in the Matrices 
dialog box with the appropriate number of rows and columns (here, 5 rows and 1 column), followed by OK. Then fill 
in the placeholders in the vector. 



x

2.2

0
3.56

9.9
13  

 
Define an index variable. Type i:0;4 See on screen 

i 0 4..  
 
Type @ and fill in the middle placeholders on the y and x axes with f xi

 and x i
. The result should look similar to 

this: 

f xi

xi

5 0 5 10 15

50

100

150

200

 

Here, the difference with plotting a function of a range variable is that the horizontal axis does not have to be in even 
increments (such as 1, 2, 3, ..., 10). Rather, it can be any set of numbers you may wish to plot. 
 
Graphing Two or More Functions 
Plotting multiple functions over a single domain on a single graph is straightforward. For example, suppose you want 

to plot both 
1
z

 and z 2  on one plot. It's easy! Just type the two expressions separated by a comma and then type @: 

 
Type  1/z [Spacebar] , z^2 @ [Enter]  You'll see a graph similar to this: 



1
z

z2

z z,

10 5 0 5 10

10

5

5

10

 

In this example both expressions are plotted over the same default range of values, but you could use two separate 
range variables if you wish. Try it out in your worksheet window now. 
 
Type f(x):sin(x) See on screen 
 

f x( ) sin x( )  
 
Type g(t):t^3 See on screen 

g t( ) t3
 

 
Type x:-10,-9.9;10 See on screen 
 

x 10 9.9, 10..  
 
Type t:-2,-1.9;2 See on screen 
 

t 2 1.9, 2..  
 
Then, 
• Type @ in some blank space. 
• In the middle placeholder on the horizontal axis, type x,t. 
• In the middle placeholder on the vertical axis, type f(x),g(t). 
• Type [Enter]. 
 
Your result should look like this: 



f x( )

g t( )

x t,

10 5 0 5 10

10

5

5

10

 

As you can see, plotting more than one function is simple --- just separate your arguments with a comma (,).  The same 
syntax holds for plotting multiple traces using vectors and functions of vectors.  

  

  
Lesson 12: Formatting Math and Text 

 

You can easily modify the way text and math appear in your worksheet. You can select different default fonts, sizes, 
and styles using the controls on the Format Bar that appears in the Mathcad window. (If the Format Bar is hidden, and 
you want to see it, make sure Format Bar on the View menu is checked.) If you're used to working with a word 
processor, this should be familiar. 
Definitions for plot: 

x 1 1.1, 10..  
For example, suppose you want to make the following style changes to the math and text in your worksheet.  

f x( ) 2 x 5( ) 2. 5
2

x. 2  

• In the text region, make the word "Here" appear in Courier 12-point bold. 
• Change the math fonts to Times New Roman 12-point bold italic. 
 
Here is a graph of f(x). 

f x( )

x
0 5 10

40

20

0

20

 

 
 



To practice, create  some regions in your worksheet window by dragging them over. The directions to make these 
changes follow. 
 
Formatting Text 
Here are the steps for changing the font and size for selected text:  
• Drag-select or double-click the word "Here" in the text region above when you are in your worksheet window. 

The selected word will appear in reverse video.  
• Now choose your fonts and point sizes from the drop-down lists in the Format Bar, and click on the appropriate 

buttons for special effects like boldface, italic, etc. 
Further text formatting options are available by choosing Text from the Format menu. 
 
Text Styles and Templates  
You can access current text styles from the first drop-down list in the Format Bar. To make a new text style, choose 
Style from the Format menu. If you want to save your styles to use in new documents, save this file as a template. You 
can then open the template and all your styles will be available for new documents. You may want to examine the built-
in styles and templates which you can see when you choose File New or in the Template directory. 
 
Formatting Math 
To change the math fonts, first notice that Mathcad distinguishes between variables (names of variables and functions 
in math regions) and constants (numbers), and it lets you apply different font tags to each. Just click on a variable or 
constant in a math region and use the Format Bar or choose Equation from the Format menu to make any changes 
you want for variables and constants. 
Mathcad also lets you highlight equations to emphasize them. Just click on an equation and choose 
Properties/Highlight Region from the Format menu in the main worksheet window.  To select different default colors 
for the worksheet background and equation highlighting, choose Color from the Format menu. 

 
 
  

  
Chapter 13: Formatting Results 

 

Now that you've learned how to get results, both numerical and graphical, there are a few tips you should know for 
formatting your results in Mathcad. Suppose you define some function using the following steps: 
 
Define the variables as constants 
Type P:500 See on screen 

P 5000  
 
Type r:.07 See on screen 

r .07  
 
Type n:365 See on screen 

n 365  
Define A as a function  of t , i.e. A(t)  
Type A(t):P*(1+r/n)^n*t See on screen 

A t( ) P 1 r
n

n t.
.

 
Get the results for different values of t 
Type A(3)= See on screen 

A 3( ) 6.168 10 3
=  

 
This is a compound-interest calculation. Notice that by default Mathcad displays the result (highlighted above) in 
exponential form if it's larger in absolute value than 1000, and the result is shown by default with three places after the 
decimal point. Suppose your calculation involved currency and you wanted to see the result in nonexponential form 
with two places after the decimal point. To change the format of the result:  



• Double-click on the result (A(3)=), or click on the result and choose Number from the Format menu. 
• Notice that the Number Format dialog box pops up. 
• Change Exponential Threshold from 3 to 6 (or another value > 3). 
• Change Displayed Precision from 3 to 2. 
• Click on OK. 
A 3( )  would now display as 

A 3( ) 6168.27=  
 

This changes the exponential threshold locally -- i.e., only for A 3( ) . If you want to change it for the entire 
worksheet, 
 
• Click on a blank part of the worksheet. 
• Select Number from the Format menu. 
• Change Exponential Threshold to the desired number. 
• Change Displayed Precision to the desired number. 
• Click on OK. 
 
Under Number Format, you can also control, among other characteristics: 
 
• Complex tolerance 
• Zero tolerance 
• The radix of the result (octal, hexadecimal, or decimal) for integer values. 
 
Plots, too, are easy to format via a dialog box you can summon by double-clicking on a result (plot), or by choosing 
Graph from the Format menu. 
 
Suppose you want to change the traces on the following plot: 
 
Type f(x):sin(x) See on screen 

f x( ) sin x( )  
 
Type g(y):cos(y) See on screen 

g y( ) cos y( )  
 
Type x:-10,-9.9;10 See on screen 

x 10 9.9, 10..  
 
Type y:-2,-1.9;2 See on screen 

y 2 1.9, 2..  

f x( )

g y( )

x y,

10 5 0 5 10

1

0.5

0.5

1
 



To create the plot above: 
 
• Type @ in some blank space. 
• In the placeholder on the horizontal axis, type x,y . 
• In the placeholder on the vertical axis, type f(x),g(y). 
• Type [Enter]. Notice that the traces are different colors. To reformat the plot, 
• Double-click near the center of the plot to see the X-Y Plot Format box. You can also access this dialog box in 

your main worksheet window by clicking on a plot and choosing Graph/X-Y Plot Format in the Format menu. 
• Click on the Traces tab. 
• Click on trace 1, and change the Color to green (for example). 
• Click on trace 2 and change the Line to dadot (for example).  
• Click on OK. 
 
Experiment with the different options to see how you can alter the trace types and other graph characteristics. For 
example, you could end up with this plot . . . 

2 1 0 1 2

1

1

 

. . . or with . . . 

2 1 0 1 2
2

0

2

 

You can also make your plot log scaled (if appropriate), put in grid lines, set markers for emphasizing certain areas of 
the graph, create legends and axis labels, even create a title for the plot. Be sure also to try clicking once on a plot when 
you are in the main worksheet window and then select Trace or Zoom from the Graph Palette. And, of course, you 
can stretch the plot to make it wider or longer by dragging the sizing handles you see at the right and bottom edges 
when you click on a plot in the main worksheet window. 

 



  

  
Lesson 14: Using Units 

 

One of the handy features of Mathcad is its ability to track standard units during calculations and to convert the units of 
calculated quantities automatically. For example, you can define a variable in terms of the built-in unit kilometers 
simply by multiplying a number by km. Here we define the radius of the Earth and a surface area function: 
 
Type r:6370*km See on screen 

r 6370 km.  
Type A(r):4*p[Ctrl]g*r^2 See on screen 

A r( ) 4 π. r 2.  

(The symbol π is also available on both the Arithmetic Palette and the Greek Symbols Palette.) 
Then you can evaluate these expressions directly, or perform more extensive calculations involving them:  
 
Type A(r)= See on screen 

A r( ) 5.099 10 14 m 2=  
 

Notice that the result is automatically shown in terms of the base units of your default unit system -- in this case SI. To 
see what the surface area of earth equals in hectares, click once on any part of the equation below and notice the 
trailing black box on the right-hand side. Double-click on this black box to bring up the Insert Unit dialog box. Then 
double-click on one of the displayed units to replace the units shown.  

4 π. r 2. 5.099 10 14 m 2=  
The result in hectares is 

4 π. r2. 5.099 1010 hectare=  
This principle holds for all of the Mathcad built-in units, which is a very extensive list, as well as for any units you may 
wish to define yourself. To see the list of built-in units in Mathcad, choose Unit from the Insert menu. 

w 100 joule.  
w 100 m N=  

µm 10 6 m.  
smoot 5.23 ft.  

smoot 1.594 10 6 µm=  

µm 6.273 10 7 smoot=  
 

The units feature is also very convenient because it lets you know if you have made a mistake in the units in your 
calculations. For example, the force calculation below should end up in newtons (or an equivalent force unit) . . . 

a 10
m

sec
.

 
 
mass 2 kg.  
 
F mass a.  
 
F 20 s newton=  
 

but it appears to have an extraneous factor of seconds. Looking closely at the statements in the calculation, you can see 

that the definition of the acceleration a is missing a term of sec 1
.  



  

  
MathCad Programming (Works with Mathcad Professional Only)  

 
Programs make it easy to do tasks that may be impossible or very inconvenient to do in any other way. This is because 
a program has many attributes associated with programming languages including conditional branching, looping 
constructs, local scoping of variables, error handling, and the ability to call itself recursively. 
What is a program 
 
 
 

What is a program?  

 
A program is simply an expression made up of more than one statement (available in Mathad Professional only). If you 
click on the examples below, you'll see how they look when written as a program rather than as a single expression. 
 

 
Despite the underlying equivalence between programs and simple expressions, programs offer two distinct advantages: 

• When you use control structures like loops and conditional branches, a program can become far more flexible 
than a simple expression could ever be. 

• A program made of several simple steps is often much easier to create than an equivalent, but far more 
complicated expression draped with parentheses. 

 
 

Defining a program (Mathcad Professional only) 

 
To following steps illustrate how to define a the program 
•  

• Type the left side of a function definition followed by the assignment operator ":". 
 
• Click on the Math toolbar to open the Programming toolbar containing the programming operators. 
 

 

 



 
 
• Click the "Add Line" button or press ]. This creates a vertical bar  
 
 

with a placeholder for an additional program statement (a program can have any number of statements). 
 
 
• Click on the top placeholder, type "z" and click on the local assignment button.  
 
(Be aware that the definition of z is local to the program. It is undefined outside the program and has no effect 
anywhere but inside the program. You cannot use the Mathcad's usual assignment operator ":=", inside a program. You 
must use the local assignment operator represented by "<-".) 
 
• Complete the local assignment by typing "x/w" in the placeholder to the arrow's right. 
 
The last placeholder should always contain the value returned by the program. Type "log(z)" into this placeholder. 
You can now use this function just as you would any other function or evaluate it symbolically. 

 

Conditional statements (Mathcad Professional only) 

 
 
Use a conditional statement whenever you want a program statement to execute only upon the occurrence of some 
condition as in the following program 
 

To insert a conditional statement: 
• Click on the placeholder into which you want to place the conditional statement. 
• Click on the Math toolbar to open the Programming toolbar containing the programming operators. 
• Click the "If" button or press Shift+]. Do not just type the word "if". 
• In the right placeholder, type a boolean expression. 
• Click the "Add Line" button to insert placeholders for additional statements if necessary. 
• Click in the remaining placeholder and click the "otherwise" button. Do not just type the word "otherwise". 
• In the remaining placeholder type the value you want the program to return if the condition is false. 

Note: 

If you use more than one "if" statement before an "otherwise" statement, the "otherwise" statement is executed only 
when all the conditions are false. 
 
 

 

 

 

 



 
 

Program loops  

 
A loop is a program statement that causes one or more statements (the body of the loop) to execute repeatedly until a 
particular condition occurs. There are two kinds of loops: 
• "For" loops are useful when you know exactly how many times the body of the loop should execute. 
• "While" loops are useful when you want to stop execution upon the occurrence of a condition but you don't know 

exactly when that condition will occur. 
 
When using loops, you may need to break out of them or control particular iterations. 
 
 
 
 

"FOR" LOOPS 

Use a "for" loop when you know exactly how many times you want the body of the loop to execute.  
 

 
To insert a "for" loop 
 
• Click in the placeholder into which you want to place the "for" loop. 
• Click on the Math toolbar to open the Programming toolbar containing the programming operators. 
• Click on the "for" button or press Ctrl+". Do not just type the word "for". 
• In the placeholder to the left of the "e", enter the iteration variable. 
• In the placeholder to the right of the "e", enter the range of values to be taken by the iteration variable (although 

you will most often use a range variable here, you can also use a vector, a list of scalars, and vectors separated by 
commas). 

• Click the "Add Line" button to insert placeholders for additional statements if necessary. If you want the body of 
the loop to execute until the occurrence of a condition but you don't know exactly how many times this will take, 
use a "while" loop instead. 

 
 
 
 
 

"WHILE" LOOPS 

Use a "while" loop whenever you want a set of statements to keep executing until a condition is met. Make sure you 
have a statement somewhere that makes the condition false. Otherwise the loop will execute indefinitely and you will 
need to stop it by pressing Esc. 
 

To insert a "while" loop: 
• Click in the placeholder into which you want to place the "while" loop.  

 

 



• Click on the Math toolbar to open the Programming toolbar containing the programming operators. 
• Click on the "while" button or press Ctrl+]. Do not just type the word "while". 
• In the placeholder to the right of the "while", type a boolean expression. Click the "Add Line" button on the 

Programming toolbar to insert placeholders for additional statements if necessary. 
• In the placeholder below the "while", enter the statement you want to execute repeatedly. Use the "Add Line" 

button to insert placeholders for additional statements if necessary. 
 
"While" loops are useful when you want to stop execution upon occurrence of a condition and you don't know exactly 
when that condition will occur. If you know exactly how many iterations you want, use a "for" loop instead.  
 
 
 

"BREAK" STATEMENT 

Use a "break" statement in a loop whenever you want to halt execution in a loop. 
 
 

 
To insert a "break" statement: 
 
• Click in the placeholder in which you want to put the "break" statement. 
• Click on the Math toolbar to open the Programming toolbar containing the programming operators. 
• Click on the "break" button or press Ctrl+{. Do not just type the word "break". 
 
When Mathcad encounters a "break" statement in the body of a “for” or “while” loop: 

1. The loop ceases execution and return the most recent value computed. 
2. The program execution then continues with the next line of the program after the loop. 

 
 Controlling iterations in a loop 
 
 

Controlling iterations in a loop 

Program loops are designed to continue until a certain condition is met or after a certain number of iterations. 
However, you may want to halt a loop during a certain iteration and continue with the next iteration. To do so, use a 
“continue” statement. 
To insert a "continue" statement: 
•  

• Click on a placeholder into which you want to place the "continue" statement. 
• Click on the Math toolbar to open the Programming toolbar containing the programming operators. 
• Click on the "continue" button or press Ctrl+[. Do not just type the word "continue". 
• When the program encounters a “continue,” it halts the iteration, goes to the nearest outer loop, and continues 

with the next iteration. 
 
 

 

 



Returning a value from a program 

By default, a program returns whatever is on the last line. However, you can return a value located elsewhere in the 
program by using a “return” statement.  
 
 

To insert a "return" statement: 
• Click on the placeholder into which you want to place the "return" statement. 
• Click on the Math Toolbar to open the Programming Toolbar containing the Programming Operator. 
• Click on the "return" button or press Ctrl+|. Do not just type the word "return". 
• In the placeholder to the right of the "return", type whatever you would like to return. 
 
"Return" statements are useful when you want to return a value from a particular loop. 
  
Trapping errors 

Trapping errors in a program 

 
To return an alternative value when an error is encountered in an expression, use the “on error” programming operator: 

• Click on the placeholder into which you want to place the "on error" statement. 
• Click on the Math toolbar to open the Programming toolbar containing the programming operators. 
• Click on the "on error" button or press Ctrl+'. Do not just type the words "on error". 
• In the placeholder to the right of the "on error", type whatever you would like to return, assuming it can be 

evaluated successfully. 
• In the placeholder to the left of the "on error", type whatever you would like to return if the default return 

expression cannot be evaluated. Use the "Add Line" button to insert placeholders for additional statements if 
necessary. 

 
The right-hand expression is evaluated and returned if no errors occur. If an error occurs, the left-hand argument is 
returned. 
  

 

 



 

Recursion 

Recursion is a powerful programming language that involves defining a variable in terms of itself as shown in this 
example:  
 
Recursive function definitions should always have at least two parts: 

1. An initial condition to prevent the recursion from going forever, and 
2. A definition of the function in terms of a previous value of the function. 
 
The idea is similar to that underlying mathematical induction: if you can get f(n+1) from f(n), and you know f(0), then 
you know all there is to know about f. Keep in mind however, that although recursive function definitions, despite their 
elegance and conciseness, are not always the most computationally efficient definitions. You may find that an 
equivalent definition using one o f the iterative loops will evaluate more quickly. 

Evaluating a program symbolically 

Once you’ve defined a program that you want to evaluate symbolically:  

1. 

(1) Type the name of the function or variable name which is defined in terms of a program. 

 
2. 

(2) Press Ctrl +Period to insert the right arrow representing the symbolic equal sign.

   

  
Where to Get More Help  

Congratulations -- you've learned the basics of working with math in Mathcad and know about producing text and 
graphs, too! Enjoy the rest of your explorations. 
Further help is available right in Mathcad in a variety of forms:  
 
• ToolTips 
• QuickSheets 
• On-line Help 
• Context-Sensitive Help 
• MathSoft World Wide Web Site 
• Other Resources 
 
Each of these functions is described in more detail below.  
 
ToolTips 
Let your mouse pointer hover over a palette or toolbar button for a few seconds, and you'll see an explanatory tool tip 
displayed near the button: 

 



 

Look also on the message line at the bottom of the Mathcad application window for helpful tips and shortcuts. 
 
Resource Center and QuickSheets 
To help you get going fast and keep you going beyond the basics found in the tutorial, Mathcad comes complete with 
QuickSheets. QuickSheets provide mathematical shortcuts for frequently used analyses -- from graphing a function to 
solving simultaneous equations to the analysis of variance. There are more than 300 QuickSheets in all. To open the 
QuickSheets section, choose QuickSheets from the opening page of the Resource Center. Worksheets relevant to this 
the course Dynamics Systems I at FAMU-FSU College of Engineering, Mechanical Department, are also reproduced 
and attached with this manuscript in the Appendix. 
 
On-line Help  

Familiar on-line Help provides detailed, step-by-step instructions for using all of Mathcad's features, mathematical and 
nonmathematical. Press [F1] at any time, or choose Help Topics from the Help menu, or click on the Help button on 
the toolbar. 
 
Context-Sensitive Help 
A useful context-sensitive Help feature can link you to the full Mathcad Help system from within your Mathcad 
worksheet. If you're not sure about searching for the topic you're interested in, just click on error messages, operators, 
and functions right in your Mathcad worksheet and press [Shift][F1] to display the relevant Help screen.  
 
MathSoft World Wide Web Site 
If  you have access to the Internet,  you can link directly to MathSoft's World Wide Web Site for Mathcad files, 
technical support information, and more. You may use your usual Web browser (e.g., Netscape Navigator, Microsoft 
Internet Explorer, Mosaic, etc.) to visit the MathSoft Home Page at http://www.mathsoft.com/. 
 
MathSoft Collaboratory 
You can access the Collaboratory on the MathSoft internet site through the File Menu. Use these forums to post 
questions and problem files for other users who may have similar interests.  
 
Other Resources 
The popular Electronic Book, The Mathcad Treasury, by Paul R. Lorczak, provides a hands-on guided tour through 
the mathematical features of Mathcad. Two chapters from this book are included in the Resource Center. Any 
mathematical background needed to understand how each feature works is discussed, and then the underlying 
algorithm behind the feature is presented. Furthermore, a wealth of tips, techniques, and working examples are 
provided to help Mathcad users work more effectively with Mathcad. For more information about this and other 
Mathcad Electronic Books, contact your local sales representative or reseller, or contact the MathSoft Sales 
Department: phone 1-800-MATHCAD, e-mail sales-info@mathsoft.com.  

 
 


